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Introduction
Krita is a free, open source digital illustration program. The full name is Krita Desktop. It’s
strongly integrated with graphics tablet hardware, although a tablet is not required. Krita is used
for creating digital art such as illustrations, comics, matte painting, and animations. It has some
vector drawing support. It also is useful for editing photographs. Krita runs on Windows 10, Mac
OSX, Linux, Android, and Chrome OS.

Commercial Equivalents: The closest commercial software is Adobe Photoshop. Photoshop
has more features, although Krita has a few features not found in Photoshop. There is also a



commercial version, Krita Studio, developed for the movie industry which offers paid support.
Corel Paintshop is another commercial alternative to Krita.

Open Source Alternatives: The older, more complex and more feature rich open source
graphics editor is GIMP. Generally GIMP and Krita are considered equivalent with Krita a bit
more elegant in design and art creation oriented. GIMP is more about photo editing.  Another
simpler open source graphics editor is Pinta.

The Simplest Possible Start
To take a first step is very simple in Krita. Launch the software and on the default screen click
on “New file” under Start.

This brings up the properties of the new file dialog. Click on the “Create” button to create a
default drawing.



Now Krita brings up the default drawing surface with tools around the edge.

The brush icon on the left should be highlighted by default. Set a brush size at the top by click
and drag in the blue slider. Choose a color on the right top if you want.

Then draw your line image with the mouse.

You are on your way to your artistic masterpiece. There’s
countless steps and tricks to refine the artwork, but each step
just takes practice.



Download and Install

The free download for different platforms is at: https://krita.org/en/download/krita-desktop/
The current web page looks like:

There are several Windows versions of Krita. Most newer computers are 64 bit systems, and
much older computers are 32 bit systems. There are portable versions of Krita for Windows
which do not require installation but can be run from a USB flash drive or external drive.
There is a Linux Appimage version of the most recent Krita, although most Linux distro’s have
an older version of Krita in their software repositories.

Krita is available from the Google Play Store as an app. This is optimized for tablets and
Chromebooks, not for phones.

Download and install just like most other software on that operating system.
After installation, the default Krita launch screen looks like:

https://krita.org/en/download/krita-desktop/


Menus are across the top, standard tools are on the left, and dockable tool properties are on the
right. The real power and ease of use comes with Krita shortcuts when running a graphics
tablet.

Digital Image Basics
The background concepts of digital images may already be familiar to you. If not, this section
covers the basics so you can configure Krita for your art project. The concepts to know are pixel
vs vector, and color depth.

Pixel Graphics

Pixel images are made of many tiny mostly square boxes of light called pixels. Each pixel-box is
only one color. From a distance all the pixels blend into a smooth image.For example, 1080p
television images are a grid 1920 x 1080 or 2,073,600 pixels. This means 1920 columns and
1080 rows of pixels. This is quite an advancement from the early days of computer monitors in
the 1980’s which were 320 x 200 pixels. Modern monitors are 4K (four times as many pixels is
1080p) or even 8K resolution. When creating a new digital image, the first step is to set the pixel
size. The larger the number of pixels and higher the resolution, the larger the file size on disk.



The Krita new document dialog box..

Complex images like photographs of landscapes are best represented as raster images.

Standard file extensions for raster graphics files include: jpg, jpeg, png, tiff, bmp, gif.

Color Depth
There are two general color models, light based and pigment based. RGB is a light based
model where all colors are made by combining red, green, or blue lights. Computer monitors
and web pages use standard RGB or sRGB. Another light based system is HSV (Hue,
Saturation, Value or HSB in Photoshop). These terms also show up in raster graphics software.



RGB model from Wikipedia
https://en.wikipedia.org/wiki/RGB_color_model

In Krita, as in most raster graphics software, there’s a way to select colors based on their RGB
values. When creating a new document in Krita, there is the option to set the color model. RGB
is the default.

Paint or Ink based CMYK
Paint or ink based colors are described with CMYK. When printing a digital image it may be
converted to CMYK. There can be some color translation when converting from RGB to CMYK
so sometimes the printed image looks different than the one on the monitor. The 4 toner
cartridges in a color printer are the values Cyan, Magenta, Yellow, Key ( also called Black).

Image from Randy Heinitz 2013

Bits Per Channel
Almost all computer monitors, web browsers and devices like smartphones only have 8 bits

allocated for each RGB channel. Since computers work in binary values per color2 8 = 256
channel so the range of each color channel is 0-255. Thus, the default number of bits in each
color channel is 8, so a pixel is described by three numbers from 0-255. Each pixel on the
screen has three values R (0-255), G (0-255), B (0-255). Optionally images support an Alpha
channel (0-255) which controls the transparency of the pixel. 0 means fully transparent and 255

https://en.wikipedia.org/wiki/RGB_color_model


is fully opaque. JPEG file formats don’t support Alpha channel values, but PNG and TIFF do
support an Alpha channel.

Other graphics software may define a pixel as 24 bits (3*8=24) which is only RGB, or 32 bits
(4*8=32) or RGBA which contains an alpha channel..

When creating a new document in Krita it gives the option to have more than 8 bits per channel.
The real world contains a much wider range of brightness than can be described with 8 bits. For
some uses like 3D model lighting or analog photograph processing, there is the option in Krita to
make 16 or 32 bit channels. These images have to be stored in special file formats, and can’t
display on regular digital devices without conversion to 8 bit for display.

The 8 bit RGB channel description of a color is a hexadecimal value, preceded by a hash ( # )
symbol. For example,#71e30e would describe a lemon green RGB color. In color selection Krita
will display the hexadecimal code for a color in addition to the decimal R (0-255), G (0-255), B
(0-255) form of the number. For example #71e30e is three groups of two characters. Red (71
hex or 113 decimal), Green is e3 hex or 227 decimal, and Blue is 0e hex or 14 decimal.
In hexadecimal RGB #000000 is black, #FFFFFF is white and identical R,G,B values like
#AAAAAA means grayscale.

Vector Graphics
Vector images are not made of little boxes (pixels), they are made of points, curves, and fills.
The advantages of vector images are they have smaller file sizes, and they can scale to any
size without loss of resolution.

(Image from Wikipedia https://en.wikipedia.org/wiki/Vector_graphics showing how vector images
continue to be crisp even when zoomed in.)

https://en.wikipedia.org/wiki/Vector_graphics


In order to display a vector image file, the computer must convert the mathematical vector
description to pixels. This slows down image display slightly but on modern computers it isn’t a
big deal.
Fonts, such as TrueType or OpenType, are vector based so they can be scaled without showing
jagged edges.

Although Krita is primarily a raster graphics editing program, Krita 4.0 and above do have some
vector editing capabilities, and can import and export svg files. Krita has more vector capabilities
than Photoshop.

The most popular open source program for vector graphics editing is Inkscape. Krita and
Inkscape can copy and paste svg 1.1 images between them.

Commercial vector graphics programs are Adobe Illustrator, and Corel Draw.

Standard file extensions for vector graphics include: svg (most popular), eps (mainly for print), ai
(Adobe Illustrator files)

Tablet Setup
Although a mouse or touch screen works well with Krita, a graphics tablet has several
advantages.

First, the pen is a more natural user interface than a mouse. A pen allows more precise
positioning of the drawing cursor.

Second, most graphics tablets are pressure sensitive. Krita allows brushes or pens to vary in
width or transparency based on the pressure applied by the pen stylus. This behavior is more
like a physical paintbrush and pencil and can seem natural. It is also much faster than
constantly changing the brush width with screen settings.

These two brush strokes were made in Krita, one using a
mouse and one using a pressure sensitive tablet.The
mouse based stroke only has one level of darkness, the
pressure sensitive tablet stylus allowed continuously
varying levels of darkness.



Configure Tablet Settings
Most graphics tablets come with specialized driver software that allows you to set properties of
the tablet. Wacom tablets are the most famous (and expensive) tablets, but other brands like
XP-PEN come with software as well.

The XP-Pen tablet setup dialog (above) allows you to define what is a double click, what area of
the screen maps onto the tablet, and which
monitor to use on a multi-monitor setup.The
stylus often has two buttons, one is usually for a
right click. A momentary press of the stylus tip
works like a mouse click, and two presses works
like a double click.

To the right is the Wacom tablet setup dialog



Configure Tablet Buttons/Keys

Most tablets also have buttons/keys on
the tablet which can be defined. If the
“Express Keys Settings” button on the
XP_Pen dialog is selected, the dialog
appears which lets you define what the
buttons do.

Document (Image) Manipulation

New Document
When first opening Krita a new document can be created by clicking on the link under Start.
New documents can also be created from the File menu, from the keyboard with shortcut
CTRL+N., or by clicking on the dog-eared page icon.



Clicking New Document
brings up the create
dialog box where
properties are specified.

When creating a new
document the default is a
custom document where
you specify width, height,
channels, etc.

The “Predefined” dropdown menu on the Create Document dialog gives you various standard
document formats to choose from. To create a new Predefined size, give the image size a name
and click the Save button. Height and width can be reversed by clicking on the horizontal or
vertical square at the right of the size area.



You can also select a
template on the left (below
custom template) which
pre-configures the
dimensions, aspect ratio,
background lines, and
some details like layers

Here’s some of the
templates for various
types of comics.



You can also make your own template for particular styles you use frequently. The current
document can be made a template by clicking on “Create Template from Image…” on the File
menu. It brings up a dialog box to save your template under any category.

In the Content tab of the new document dialog box, the name, background color, description
and other properties of the new document can be defined.

In the new document dialog Krita also gives you the option to create a new document from any
image stored in the operating system clipboard..



If a color profile is missing
from the clipboard image, it
will ask for the common
defaults: web and monitor.

Close Document

To close the current document click on the X in the upper right corner
Chose Close or Close All on the file menu, or use the keyboard shortcut CTRL+W

Saving a Document
The default file format for Krita is “*.kra”. This is the preferred format if you are going to work on
the image again in the future. This *.kra document format saves the layers, brush choices, etc.
When you select “Save As” on the File menu, it give the option of what format to use. Unless
you wish to share the file with other programs, Krita Document *.kra is the better option.



Later you can export the document in a standard graphics format by selecting something other
than the *.kra format.



User Interface

Workspaces
The standard (default) user interface arrangement for Krita is the default workspace.

The menu is at the top, with File on the left and Help on the right. Below the menus is the
standard toolbar with new file, open, save, undo, redo, and current brush settings (since the
brush is the current tool). Below the toolbar are the tabs for each image if there are several
images open. At the bottom of the page is the status bar with current brush on the left, file color
and size in the middle, and zoom slider on the bottom right.

The standard tools are in the toolbox on the left, and the image to edit in the middle viewport.
On the right are various dockers. By default the color selector is in the upper right, and the
common brushes on the lower right. Other software may call these panels or windows but Krita
calls them dockers. A window in Krita (from the Window menu) is actually a new instance of
Krita. If you have multiple monitors, it can be handy to have multiple versions (windows) of Krita
running simultaneously.

You can change the current user interface workspace by clicking on the workspace dropdown in
the far right or from the Window->Workspace menu. This document uses the default workspace.



Usually we work in the Default workspace unless creating a specialized document like a vector
image.

Dockers

Advanced Color Selector
One of the default tool dockers is the Advanced Color Selector.

Select the hue by clicking in the color wheel circle around the outside. Click value and saturation
by clicking in the triangle or the bars across the bottom.



Layers
The Layers docker is in the middle right by default. The various layers are in a list. The eye icon
will make the layer visible or invisible. The Opacity of the layer can be adjusted by click and
drag in the slider. This is handy for tracing a background image. Double click in the layer name
to change the text description. The icons on the right can lock the layer, can examine the alpha

At the bottom, will add a layer, will duplicate a layer, change the order of

the layers, changes the layer properties like background color, and the trash can
deletes the selected layer.

Layers can be
grouped together by
shift-clicking multiple
layers in the layer
docker, then right
click and select group
from the popup menu.
This can be handy
when several layers
relate to one object in
the illustration.

Using many layers is
quite helpful in digital
graphics.



Brush Selector

As you imagine from a drawing program, there are many possible brushes available. Artists
tend to develop their favorite brushes, especially for a particular style of painting. They may end
up using just one brush for an entire painting.

The brush docker is a bit redundant since the brush selection can be brought up at any time by
clicking on the grid-like brush dropdown in the middle of the toolbar.



Adding and Removing Dockers
A right click in the toolbar at the top will bring up a list of
possible dockers. The visible dockers have a checkmark
beside their name.

Another way to close a docker is the close box (X) at the
upper right of each docker.

Right click in the upper toolbar to bring the docker back.

A third way to hide and show dockers is from the settings
menu, choose Dockers.



Floating Dockers
To detach a docker from the side and make it float, click on the icon next to the close icon on the
docker.

Here the Advanced Color Selector has been “undocked” and is floating.

A floating docker can be dragged to one of the borders of the Krita window and it will
automatically dock itself.

The size of dockers can be changed by clicking and dragging up or down at the bottom of the
docker.

Saving a UI as a Workspace
A particular arrangement of dockers can be saved
by clicking on the dropdown at the upper right of the
toolbar, entering a name, then saving that
workspace.



Navigation
Changing the view of the image is called navigation. It doesn’t change the image itself. Typical
navigation actions are zoom, pan, or rotate.

Most graphics software provides multiple ways/shortcuts for the same UI action. This speeds up
workflow. Krita is no exception.

Zoom
To zoom in or out there several methods in Krita. The zoom slider at the bottom right is one way
for precise scaling.

Preset zoom levels can be set from the pop up to the left of the zoom
slider.

When in brush mode (brush icon is selected in the toolbox) right click brings up many tools. The
lower right tool is the zoom slider. Click and drag the slider to zoom.

The zoom tool in the toolbox will also do zoom. Left click zooms in. CTRL+click zooms out.

The keyboard has zoom shortcuts as well. “+”, often the “=” key too, will zoom in, “-” will zoom
out. “1” will return to 100%.
The mouse (middle) scroll wheel zooms in and out.



Pan
The scroll bars on the bottom and right of the image will pan left/right or up down.

The hand tool in the toolbox (next to the zoom magnifying glass) will pan with left click and drag.

Click (press) and drag with the middle mouse button (often the scroll wheel) will pan. This can
be the fastest way to pan when using a mouse.

Rotate
Right click when any brush tool is selected. This makes visible the brush pop-up toolbox. Click
and drag the white circle around the rim to rotate the image.

The 4 key or CTRL+[ rotates the image counter clockwise, the 6 key or CTRL+] rotates
clockwise. The 5 key restore the image to zero degrees rotation.
Shift + the middle mouse button allows dragging rotation.

Mirroring
The image view can be flipped horizontally with either the M key or the View -> Canvas ->Mirror
View from the View menu. This image isn’t changed, just the view of the image.

Photoshop Spacebar Shortcuts for Zoom, Pan, Rotate
The Photoshop spacebar shortcuts are available in Krita. Spacebar + left click and drag left or
right will pan.Spacebar + CTRL + click and drag up and down zooms in and out. Spacebar +
shift + click and drag will rotate. Spacebar + alt + … adds stepping behavior to zoom, pan, and



rotate. For artists who use Krita, Photoshop and Adobe Illustrator, the spacebar shortcuts are
probably the easiest to memorize.
For artists who don’t use Photoshop, perhaps the middle mouse button shortcuts are fastest.

Brush
The brush tool is on the left toolbox, and can be selected from the keyboard by typing “b”.

All of the top tools in the toolbox (on the right image) relate to the brush and only
work in a paint layer, not a vector layer.

Preset Brush Types
The brush docker on the far lower right is another place to select a preset type of
brush.

The brush dropdown on the toolbar at the top of the workspace is yet another way to select a



brush.
Hovering over a brush type image for a couple seconds will pop up the details and name of that
brush. Krita comes with many brushes but even more can be downloaded from the Internet, or
even created yourself.

Search for a brush by typing in a keyword like “pencil” or “blend” at the bottom of the brush
presets panel. Only brushes matching that keyword will show up.The list of some keywords
(tags) can be seen or selected from the dropdown menu at the top of the brushes panel..



You can create your own tags by clicking on the Tag drop down.

Then right click on any brush in the panel (select all first) and assign it to that new tag.

Once brushes have been assigned to your custom
tag, then right click anywhere in the image to bring
up the brush pop-up pallet. Use the tag icon to click
your custom tag. Then only the brushes you’ve
labeled will show up in the palette of brushes. This
makes it much easier for you to find the brush you
want.



Brush Size
The size (diameter) of a brush can be set several ways in Krita.

1) The slider control at the top right of the image area will scale the size of the brush. Right
click will allow typing in a number for the brush diameter.

2) Right click on the image when the brush is selected to get the brush popup. The bottom
right of the brush popup has an arrow which will bring up a slider to adjust brush
properties such as size.

3) From the keyboard, “[“ reduces the brush size, and “]” increases the brush size.

4) When using a tablet, holding the shift key down and moving the stylus left or right will
reduce or increase the brush size.

Brush Related Tools
The other “brush related” tools are near the brush icon on the toolbox.
These tools also draw on the canvas, but in a constrained manner, unlike the
freeform brush tool. The line draws a straight line. The square draws rectangles.
The circle draws ellipses. Holding the shift key while drawing will create squares or
circles. The other tools relate to polygons, bezier curves or polylines. Experiment to
see what these tools do.



Straight line, rectangle, ellipse, closed polygon, open polygon

Eraser
Any brush-like can be turned into an eraser by clicking on the
Eraser toggle icon. Clicking again converts the brush back to
drawing mode. Eraser mode also works with the line, circle,
rectangle or polygon drawing tools.

To erase an entire layer or region, use the selection tool to identify
the area to erase, then press the “Delete” key.

Selection Tools
Selection tools are like brush related tools, but instead of drawing lines they mark an
area of the drawing for some special purpose like deletion or coloring. There are
many ways to select areas of an image. There group of dashed line tools at the
lower left are all ways to select. Selected areas are useful for color fill, zoom, etc.
Experiment to try different selection methods.

Color Selection
The foreground/background colors are selected from the upper toolbar (two boxes with arrows).
Clicking on it brings up a color selection box. There are standard colors, RGB scales, and
#hexadecimal codes. Clicking on one of the standard colors on the right will fill in the triangle



with the different saturations, and show where the color is on the hue circle.

This selects the RGB foreground color (unless HSV tab is selected). The
foreground and background can be reversed with a click.



The Advanced Color Selector docker has hue
around the outside ring, and fine tuning of the hue in
the top slider. The other two sliders control
saturation and value.
Click around the hue circle to pick different
combinations of colors. Slide the boxes to get
different values and saturations.

There are various tool options on the Options tab.
The selected color also updates the gradient, and
the foreground/background tools.

Transformation Tools

Transform  -- Move -- Crop

Crop

The crop tool (right) selects an area
of an image and allows reducing
the image to the selection. Click
and drag on the boxes in the corner
allow resizing the selection area



Right click on the selected area makes a pop-up menu of possible actions appear. Once the
selected area is correct, right click and choose crop to resize the image.

Move
The perpendicular arrows “Move” tool allows you to move selected areas around the canvas.
Select an area, then click on the Move tool or type T on the keyboard. Then drag the selected
area around the canvas.

Transform

The universal change-everything tool is the Transform. It will scale
or rotate any selection or layer.
Select some area and then click on the ragged box icon to
transform the selection. Square handles appear around the edge of
the image to shrink it in any direction. Holding the shift key down
will keep the original proportions as you scale.

Moving the cursor outside the selection area will turn it into two
arrows in a circle. This lets you rotate the selected area around the



point in the middle. The rotation point can be moved by clicking on it and dragging.

Copy and Paste
To copy a section of the image, first use a selection tool (dashed lines) to bound the region to
copy. Then go to the Edit menu and select Copy.  Edit -> Copy or CTRL+C
Then Edit->Paste or CTRL+V
Next choose either the Move or Transform tool and drag the copied area to the new location.

Shading Tools

Basic Shading Concepts
The way shading (shadows) occurs in a drawing tells the brain of the viewer a great deal about
the shape of the object in the drawing. Understanding three simple concepts of shading will
provide consistent information to the viewer.

Light Direction
Although it sounds obvious, make sure the light and shadow indicate the light is coming from
the same direction. If different parts of the image have shadows going opposite directions, the
viewer loses the sense of reality.

Most natural light sources come from above, like the sun or moon. Even most man-made lights
are placed above, on the ceiling for a more natural look. If the light is not above the object being
drawn, it helps the viewer to include the light in the drawing.

Depth of Contrast
Lighter highlight colors are usually at the top of an object, and darker shadow colors are at the
bottom. If this order is reversed the brain thinks the item is a hole not a solid object. The darker
the shading the deeper the hole appears, or the larger or more opaque the solid object.

Shading Contrast
A sharp contrast from light to dark implies a hard corner or edge. A smooth fade from light to
dark implies a rounded edge.



Shading Techniques
As with any graphics software there are multiple ways to shade an area.

First, create a new paint layer (with the + icon on the layers docker). Then make a circle using

the circle selection tool. . Then press the “shift backspace” keys to fill the circle with the
foreground color as defined by the Advanced color selector.

Soft Brush
We’ll assume the light is in the upper left of the canvas, which means you must make the bottom
right darker. Click on the brush, and choose the air brush from the brush panel since that is the
most soft edged brush. Increase the size of the brush to equal the size of the circle. (Use the
tablet or ] key or brush size slider). In the Advanced color selector choose a darker color. Then
go around the bottom of the circle with the air brush. Either keep the circle selected, since
brushes are limited to selection areas, or lock the alpha channel (far right box) to constrain the
brush color to the circle.

Next choose a darker color and go over the bottom of the circle with the darker color.



Optionally, pick a very light color, reduce the size of the brush and go over the top of the circle.

You’ve created the illusion of a solid circle using shading

Blur Tool
To try another technique, use the fill tool to flood the circle with a light shade, or shift backspace
to fill the circle with a flat shade. Either keep the circle selected or use the alpha channel lock.

Then use a basic brush to draw ever darker bands around the circle. Use the color
selector to pick darker colors. Then use the blur tool to smear the shades together.



The end result is a shaded sphere.
Although gray scale was used here, the same shading techniques work with colored shadows.



Image Menu
On the Image menu there are menu items to view the image properties, change background
color, trim, resize, mirror or perform other transformations.

Resize
In Krita there is the image (photo or drawing), and the canvas on which it is drawn. The image
and the canvas can be manipulated separately.

Resize Image
Resize the image from the Toolbox select the transform icon. (Ruffled square icon.) This allows
you to change the size of the image, although the canvas stays the same.



Resize boxes/handles appear at the edge of the image allowing scaling in any direction. The
background of the canvas shows through since the canvas stays the same size.

Resize Canvas
The size of the canvas can be
changed without changing the
size of the image using th
Image menu

Image->Resize Canvas

A dialog box appears to enter new canvas dimensions and an offset if needed.



(Resize canvas dialog)

Resize Image and Canvas
On the Image menu select “Scale Image to New Size”

This brings up the dialog box where the pixel and print sizes can be changed. The proportions
can be kept the same or allowed to vary with the chain icon to the right.



Rotate
On the Image menu is the rotate option, to free rotate or to rotate a fixed 90 degrees.



Krita Configuration

Configure Krita Settings
On the Settings menu there are many ways to customize Krita.

An artist can customize the toolbars, change which dockers are visible, change language, set
the author profile. In the Configure Krita… menu item many aspects of Krita can be customized
to improve workflow or
performance.
The Configure Krita dialog lets
the user customize keyboard
shortcuts, etc.

For older or slower computers
a couple items on the
Configure Krita Performance
tab can be altered which may
improve performance.



Krita Performance Settings
Some users consider Krita slower than GIMP or Photoshop. This is often because Krita hasn’t
been tuned for better performance.

Graphics Driver
Since Krita is cross platform it uses by default a generic graphics driver. For best performance
on Windows change the default to use Direct3D. On Linux use OpenGL.

To change the driver used for rendering, on the Krita Settings menu select Configure Krita to
adjust graphics driver.

The Configure Krita dialog has many areas to tune. On the Display tab select the renderer from
the drop down menu.

Restart Krita after changing the Renderer.

This dialog box is where many features can be customized like Keyboard Shortcuts.



Brush Smoothing
To smooth brush strokes takes quite a bit
of CPU power. For slower computers turn
off smoothing unless it is needed.
To do that, select the brush mode. Then on
the right hand side select the Tool Options
tab, the “None” for brush smoothing.

The “Weighted” and “Stabilizer” settings for brush smoothing are quite useful when tracing over
(inking) sketches to get smooth lines. If your computer is fast enough those are better settings
unless you have performance problems when drawing with brushes.


