
CHAPTER 1: Introduction
Written and copyrighted by Mark Webster

Most people learn to create digital graphics using a bitmap (raster) format. Raster or bitmap
graphic images are made of many tiny points of color called pixels.It seems the most natural
approach and is similar to physical painting. However, there are common situations like
illustrations that must scale to all different sizes, where another approach to digital art is better.
That other approach is to describe all the forms in the scene as shapes. That other approach is
called vector graphics.

Inkscape is the dominant open source (free) vector graphics software, just like Adobe Illustrator
is the dominant commercial vector graphics program. Inkscape reads and writes the
international standard SVG file format.

Pixel based graphics software like Photoshop or GIMP  treats images as a grid of tiny colored
boxes. Vector graphics software treats all images as mathematical curves and shapes. When
pixel (raster) graphics are enlarged they become ragged, blurry, and speckled. When vector
graphics are enlarged to any size they continue to be smooth, crisp shapes.

From the wikipedia article https://en.wikipedia.org/wiki/Scalable_Vector_Graphics

Vector graphics also tend to be smaller file sizes. Not every artwork is best drawn with vectors.
When images have a lot of complex detail, it becomes difficult to draw with vectors and is easier
to create or edit with pixel based software. Also, vector graphics take more computer power to
display on pixel based monitors and televisions but with modern computers that isn’t a big
issue..

Inkscape has comprehensive node editing features, bitmap tracing, layers, file export, shapes,
etc.

More about the history of the Inkscape software can be found in the Wikipedia page:

https://en.wikipedia.org/wiki/Scalable_Vector_Graphics


https://en.wikipedia.org/wiki/Inkscape

CHAPTER 2: Learn Inkscape
The Inkscape website has a menu called Learn with tutorials, books, manuals, and tips on how
to make best use of Inkscape. There is a button on the middle right called “Learning Resources”
with many helpful sources of knowledge.Once Inkscape is installed there is a Help menu which
is very handy. The entire Inkscape manual is available as an Inkscape vector document. It
opens up in a separate Inkscape window.

Within the Inkscape software there is a menu item Help -> Tutorials which contains info
explaining almost everything.

YouTube is a source of video tutorials, both general instruction and help with specific art
techniques using Inkscape. Just search for “Inkscape Tutorial”. Remember that older tutorials

https://en.wikipedia.org/wiki/Inkscape


use previous versions of Inkscape which have a slightly different user interface. This is true for
all YouTube tutorials-- search for recently released tutorials for software.

Udemy.com is a paid tutorial site that has several excellent and in depth tutorials on Inkscape.
Wait for times the Udemy courses are on sale at 90% discount.

INKSCAPE GALLERY

Artists learn and get inspiration by looking at the works of other artists. For inspiration and to
see what’s possible on the Inkscape website there is a gallery of many community created
vector images. https://inkscape.org/gallery/

Here’s a few examples from the website gallery.

https://inkscape.org/gallery/


Other examples of Inkscape art can be found on Wikimedia Commons. Just search for Inkscape
or vector graphics. A few Inkscape vector images are below..

Maps are an excellent use for vector graphics.

By Capmo - CC BY-SA 3.0, https://commons.wikimedia.org/w/index.php?curid=1284504

https://commons.wikimedia.org/w/index.php?curid=1284504


Comics or anime are well presented by vector graphics.
By Niabot  CC BY 3.0, https://commons.wikimedia.org/w/index.php?curid=3246010

CHAPTER 2: Installation
Inkscape is free and can be downloaded from the main website. https://inkscape.org/ Click on
the Download button on the home webpage. Probably you want the latest version

Uninstall previous versions of Inkscape before installing a new version.

On the Inkscape website choose Download Current Version and the website brings up the
three main operating systems to choose from: Linux, Windows, and macOS. Click on the link for
the computer you wish to use.

For example, under Windows, the three choices are:

https://commons.wikimedia.org/w/index.php?curid=3246010
https://inkscape.org/


Almost all modern computers are 64-bit so that is the safest choice.

For linux systems there are also three choices:

For macOS there is only one option, a dmg file.

Download the desired software and install the usual way. For example, on windows just double
click and answer the installation questions.

The installer can make the desktop icon which is just a shortcut. Other operating systems like
Linux may require creating a shortcut or else launch Inkscape from a menu.

CHAPTER 3: SVG Standard
Vector graphics files, usually with the extension SVG, are based on an international standard.
Inkscape files are also based on this standard, with a few extensions like layers. If you
understand what an SVG file contain then you know what the capabilities of programs like
Illustrator or Inkscape can do.

Inkscape implements the SVG objects or properties in a visual manner. An SVG file is a text file,
like XML or HTML, which describes how a browser or software like Inkscape can draw items on
a screen. An SVG file does not contain pixels, just descriptions of shapes. In theory a person



could write an SVG file by hand in a text editor, but it’s much easier to have a computer program
like Inkscape write the file for you.

SVG files have a format defined by the W3C international committee.

SVG SHAPE

The SVG standard defines basic geometric objects:
.
Basic Shape: Standard shapes which are predefined in SVG as a convenience for common
graphical operations. Specifically: ‘circle’, ‘ellipse’, ‘line’, ‘polygon’, ‘polyline’ and ‘rect’.

Inkscape has tools which create each of the basic shapes. Basic shapes can have properties or
attributes like colors, fill, border lines, gradients, etc. They are not paths but can be converted to
paths.

SVG PATH

A path is the trajectory of a curve or line. Usually this is a mathematical shape called a cubic
bezier curve which is a smooth path defined by control points.
The path is not the nodes. For example, take a long exposure of a person slalom skiing through
a series of racing poles. The trajectory of the skier would be a path. The trajectory is not the
lines connecting the poles..

In an SVG file, a path is defined as a series of (x,y) points.

Here’s a picture from the Wikipedia article on Bezier curves.

Points P0 - P3 control the path but are not necessarily on the path.

A path has many attributes like color, thickness, style. Inkscape can set all these attributes.



SVG NODES

Nodes are points that define paths. In Inkscape these appear as round circles, diamonds, or
squares. Two nodes define a straight line. Nodes can also define a bezier curve. Use the Node
editor tool to select and move nodes. Unlike control points, nodes appear on the path, at the
beginning and end of a path, and where paths change direction.
Sometimes nodes are called anchor points if they are on the path itself.

Curved lines will show with control lines (handles) to change the shape or you can drag the
curve itself

(Image from the Inkscape documentation on paths.).

Nodes can be the start or endpoint of a path for open paths.

Inkscape has several types of nodes:
● Cusp or corner nodes (like at the corners of a rectangle)
● Smooth nodes (smooth curve, like a bezier curve)
● Symmetrical
● Tangent



SVG STROKES

SVG defines strokes as more than just a path. A stroke is a path with attributes like width, color
fill, etc. For example, if you walk down the sidewalk, the imaginary line you follow is a path. The
sidewalk itself that you walk on has width and color. The sidewalk is the stroke who’s trajectory
is defined by the path you walk. To edit the shape of a stroke it must be converted to a path.

Inkscape has an object called stroke with properties that can be changed. A stroke can be

converted to a path from the Path menu and edited with the Node editor tool.

SVG FONTS

SVG files support fonts and text. Inkscape as a variety of text editing tools for the purpose of
defining text and assigning styles like font style, size, etc to the text.. Inkscape will use the fonts
installed for the current user.

SVG UNITS

SVG files can define the measurement units. Inkscape supports millimeters (mm), centimeter
(cm), inches (in), pixels (px). The units for a document are set using the File -> Document
Properties menu item.

SVG BITMAPS

SVG and Inkscape allows the inclusion of pixel/bitmap graphics into a drawing, often to use as a
reference when tracing or when converting from bitmap to vector.



SVG DEPTH/ORDER

Objects in SVG files don’t have an official z or depth, but front to back is determined by their
order in the file. Objects at the top of the file are rendered in the back of the image, objects at
the end of the file are rendered in the front of the image. This creates the appearance of layers.
SVG does have groups of elements which Adobe Illustrator and Inkscape support but this isn’t
the same as layers. Inkscape makes this depth concept more formal by using actual layers.

SVG SCRIPTS

SVG supports CSS and Javascript. Inkscape supports scripts in Python and Perl to create
Inkscape extensions. The SVG file from Inkscape can be included in a web page and
manipulated with Javascript.

SVG NOT SUPPORTED BY INKSCAPE

An SVG animate element controls or animates the properties of another element, using a
scripting language like Javascript. Inkscape doesn’t directly support animated SVG yet.
Inkscape can create vector files and then the open source program OpenToonz can produce an
animation from them.

INKSCAPE FEATURES NOT IN SVG

Inkscape has a few features not found in the SVG file format. For example, Inkscape has layers
which SVG does not.

CHAPTER 3: Inkscape User Interface
The default interface for a new installation of Inkscape 1.02 looks like:
The main toolbar is on the left. The user interface menus are at the top. A secondary toolbar is
on the right. The actual document is the rectangle in the center. The bottom is a color selector.



The Inkscape default screen has a lot of features which you’d hope for in well developed
software. We’ll go through the basics in this tutorial.

The main menu is across the top. Beneath the menu is the command bar which changes
based on what tool is selected.

The vertical toolbar on the left lets you create basic shapes, draw paths, edit meshes, and do
some fills. The vertical toolbar on the right has the more common file menu operations, zoom,



and some other tools like grid. It is easier for tablet based Inkscape users than to click icons
than use menus.
The middle of the screen is the drawing area where the canvas is displayed.
The bottom is the simplified color palette, and below the color pallet is the status bar. It also
has the fill and Stroke area. Double clicking on that brings up the fill and stroke control panel.

Hovering over a tool or icon will cause Inkscape to display a short description and the keyboard
shortcut.

INKSCAPE DOCUMENT PROPERTIES

When starting a new vector graphics project, you probably want to set the document size and
units. Go to the File - >Document Properties menu item.

It brings up the dialog box:



The default is A4 paper and units of millimeters. If you are designing for an American audience
you may want to switch to US Letter and display units of in(ches).

INKSCAPE TOOLBARS AND MENUS

The exact positioning of toolbars changes with different Inkscape releases. This tutorial uses
Inkscape version 1.02. Although the editor concepts stay the same as Inkscape evolves, the
user interface will change. You must play around with new versions to find where the tools and
controls are hidden.

Across the top of the screen are the menus for most Inkscape features.

Below the menus is the CommandsBar. Each time a tool in the left toolbar is clicked on, the
CommandsBar changes to reflect that particular tool.



The vertical toolbar on the top left of the window is the main group of tools. Most of the tools will
be examined in more detail in this tutorial. Hovering over the tool brings up a text description
and the keyboard shortcut.





The vertical toolbar on the right is mostly file operations, import and export. Other rightside tools
control display of grids, snap to, and various other properties of the user interface.

Across the bottom is the palette for color selection. A selected object’s fill and stroke color can
be changed from this palette.

Below the color palette is the status bar describing the current fill and stroke settings, layers,
objects selected, zoom, etc.

Left to right on the status bar: fill/stroke colors, opacity level, visibility, position of cursor, zoom,
window rotation.

MOVE THE CANVAS

Move the canvas up and down by rolling the scroll wheel on the mouse.  Pressing the shift key
and the mouse scroll wheel move the canvas sideways. Pressing the control key and the mouse
wheel will zoom in and out on the canvas.

Pressing the CTRL key and an up or down arrow key will also move the canvas up, down, left or
right.

Click with the middle mouse button or scroll wheel, then drag left or right to pan the canvas left
or right.

ZOOM

To zoom in, press the “shift and +” keys simultaneously. The “=” on the + key also works
(without the shift key)
To zoom out, press the “shift and -” keys simultaneously.
Click with the middle mouse button (scroll wheel) to zoom in. Shift and middle mouse button
zooms out.



Another way to zoom in is select the magnifying lens tool on the left bottom, and left click on the
part of the drawing to expand. To zoom out using the magnifying lens, hold the shift key when
clicking on the drawing area.
An easy way to zoom in specialized ways is to use zoom tools across the top that appear when
the magnifying/ zoom tool is selected.

The right side toolbar has shortcuts to many of the common zoom icons.

CHAPTER 4: Object, Shape, Stroke, Path
Inkscape defines several types of shapes mostly based on the SVG standard.

An object is anything in the document: shapes, strokes, or paths. An object can be selected and
manipulated.

A shape is a predefined SVG basic shape. Examples are rectangles, circles, polygons, cubes,
spirals, or text. A shape has properties different from a set of points like a path. A rectangle
shape has rounded or square corners. A shape has a border (outline) called a stroke, and an
interior called a fill. Generally leave a shape as it is unless specific points in the shape need to
be changed. The point edit tool won’t change any of the points in a shape unless it is converted
to a stroke or path.
However, a shape like a rectangle can be converted to strokes by selecting the object and then
on the Path menu choose Path -> Object to Path. The edit points tool can then manipulate the
points in the strokes that make up what was the shape. An additional step is needed to convert
the resulting strokes to a path. Object to path menu option will convert text directly into paths,
not strokes.



A stroke is a set of points that has a width and other properties like color and fill. The freehand
or bezier tools will draw strokes. A shape like a rectangle has a border that is a stroke. The color
and style of a stroke can be changed with the Object->Fill and Stroke dialog box. A stroke can
be converted to a path with the Path -> Stroke to Path menu.

A path is a set of points that may or may not enclose a region. If a region is enclosed, the path
can have a fill. A shape like text can be converted to a path which is the set of points that are
the outline of the letters. Similarly, a rectangle can be converted to the outline path, or a stroke
can be converted to the outline around the stroke. The menu options Path -> Object to Path,
and Path -> Stroke to Path will do the conversion to a path. The Node Edit tool will modify
individual points on paths.

SHAPE TOOLS

The shape tools let you draw and then transform various fundamental shapes. A shape is a
distinct SVG object, which is not the same as a path with nodes. The properties (color, fill, etc)
of a basic object can be edited but an object must be converted to a path on the Path menu
before editing its shape. Most man made objects are made of basic shapes: rectangles,
ellipses, triangles. These shapes plus more are in the tool icons on the left.



To draw rectangles click on the rectangle tool (on the upper left), then click and drag on the
drawing area. Similarly for the other basic shapes. The shapes can be resized and rotated after
drawing using the handles which appear when the shape is clicked on. Properties of the shape
can be defined as well.

FILL AND STROKE PROPERTIES



To control the fill and stroke properties of a basic shape, select the shape tool on the left toolbar

then on the Object menu select Fill and Stroke...

This brings up a panel box with three tabs on the right side of the screen. Here’s the “Fill” tab
with different fill styles. Roll over the icon to see what it controls. When an object in the canvas
is selected, the various fill controls become active.

There are multiple fill styles besides solid color. Two of the fill styles, gradient and pattern.



Here’s an example of the linear gradient applied to a rectangle object.

Below is an example of setting the Stroke Paint in that tab to red and the Stroke Style set to
Dashes from the “Dashes” dropdown menu.

Below the Dashes dropdown are icons to set the style of corners and layers.

The circle/ellipse tool works like the rectangle tool. Click and drag to create an ellipse.



The Polygon/star tool has options at the top on the command bar for the number of sides,

roundedness, etc. The rounded value creates interesting loops, etc.

In the illustration the RGB flat color fill was set for the polygon and ellipse basic objects on this
canvas.



The basic shape box tool lets you adjust the 2 perspective vanishing points

The spiral tool is fairly obvious although different fill effects can be fun.

Spiral tool with fill.



CHAPTER 5: Drawing Tools
SVG files created by Inkscape contain shapes, paths, strokes, fonts, and properties like color
gradients. Drawing tools in Inkscape let an artist make illustrations which contain all these SVG
items.

BEZIER PEN

The pen tool draws bezier curves or straight lines.

When selected, the command bar gives the options. For example, the straight line segments

option is selected here.

Create a line segment by clicking at one point then moving the mouse cursor to a second
location and clicking. When the mouse is down, the line is red. When the mouse button is
released, the line turns green. When double clicked, the sequence of points is finished. Each
click of the mouse starts a new line segment, and double clicking ends the path. Closing the
path by clicking on the starting point also ends the path the same as double clicking. Note that a
path must be closed to use the paint bucket fill tool.

To create curved likes, click to start the path then drag the mouse with the button down until you
reach a second location where a new curve starts and release the mouse button.. Click to start
a new curve, then drag the mouse again. Click makes straight lines, click and drag will make
curved lines. Control handles will appear to adjust the curve.



When bezier created lines are edited with the node tool, diamond shaped node symbols are
corners, square nodes are curved points with control lines.

The same shape options are available for the pencil. Triangle in (line wide to narrow), Triangle
out (line gets wider, copy to and from clipboard, etc)

The Bezier pen can make curved lines (which have control handles) or straight lines. Straight
nodes can be converted to curved nodes from the command menu of the node edit tool. See the
section in this document on Change Node Type

The Bezier pen has several modes, indicated by the icons at top. The path/node mode is the
first style, and the second icon is the spiro mode.

When clicking points in a general spiral shape, this mode will smooth out the curves into the
best spiral it can make.



Example of a spiral path.



Example of a b-spline curve forming the best shape it can between the control points.

Straight line mode does just what it says, no curves allowed.

Paraxial lines are parallel to the horizontal or vertical axes, but cannot be diagonal or curved.



Example of paraxial line segments.

Although straight lines only are created, they can be edited into curved lines later with the node
tool,

PENCIL TOOL

On the left tool bar the pencil tool is a common and powerful tool for drawing paths.

When the pencil tool is selected at the top on the command bar these options appear:

The pressure input option is when using a pressure sensitive drawing tablet.

The pencil line can be converted to a path and edited with the node tool. The path is mainly
smooth curves so most nodes have control lines.



On the command bar there are options for the shape of the pencil path, Triangle in makes the
pencil path start wide and get narrower. Triangle out makes the path get wider.
Ellipse draws a cross section of an ellipse of width defined by the pencil line. Pencil lines can be
copied to and from the clipboard for reuse later.

CALLIGRAPHY PEN



The calligraphy or brush pen draws sweeping wide strokes that narrow and get wider.

Stroke and fill properties are set from the Fill and Stroke dialog/ toolbox.

The type of pen is set from the command bar at the top in the preset dropdown.

The command bar controls properties of the calligraphy/brush pen.

Here the command bar is broken into two parts for legibility.



Notice at the far right there is a status of the fill and stroke colors, and the stroke width.
Experiment to see what these options do.

TEXT

Text is an SVG object with properties like font and size. Fonts in themselves are a specialized

vector drawing since they scale to all sizes cleanly.

Select the Ascii tool, click on the canvas and start typing. On the command bar appear
dropdowns to set the fonts, styles, size, units, line spacing, etc.



To edit text and change it’s properties, select the Text tool, click on the existing text, and then
edit. Double click to select words within the text block..



ERASER

The eraser tool deletes portions of objects.
The command bar shows options.

Here the mode is set to delete objects touched by the eraser.
An example is a rectangle with two swaths erased in the cut out from paths and shapes mode..

The two styles of deleting are cut out and clip from objects. The width of the cutout is also set on
the command bar. Whether to use pressure sensitive tablets is also an option to control width of

the cutout. .



DIAGRAM CONNECTORS

This tool creates lines that join the centers of different shapes. Useful for making flow charts or
organizational charts.

With the connect tool selected, click and drag from the center of one object to the center of
another. The centers will highlight when the mouse is over them. A connecting line will be

created between the two objects.

The command bar changes when the connector tool is selected. The first option is to make
connector lines avoid the selected object. The other options are related to avoidance too.



The other command toolbar options control how the connector lines avoid objects, including
curvature and spacing.

CHAPTER 6: Editing Tools

Select Objects

The arrow cursor will select objects like rectangles, circles, stars, cubes. The selected object
can be resized by dragging the various arrows around the edge. Selecting the object again



changes the surrounding arrows to rotation arrows. Click and drag to spin the object around the
center point.

SELECT NODES OR PATHS

To edit nodes they must be selected. Objects must be converted to paths, which contain nodes,
before they can be edited. For example, if you select a basic rectangle object,then the node edit
tool, click on the convert to path icon at the top, and nodes will magically appear around the

rectangle. Then the rectangle can be edited as a path.

Using the arrow selector tool (top of the menu bar) click and drag over a canvas area will select

multiple nodes.

When hovering over a node, it turns red. When the node is selected it turns blue. Shift click to
select two nodes.

Once a node is selected it can be dragged, deleted, or used to split the path into two paths.
Once two end nodes are selected they can be joined, etc.



When the cursor is over a path (segment between two nodes) it turns to a hand. This lets you
drag or edit the path, for example to turn a straight line segment into a curve by dragging the
path. The Bezier control handles appear to facilitate changing the shape of the path.

Also, selecting the nodes at the endpoints of a path will make the control handles appear.

Selecting a node on a curved path will also cause the control handles to appear.

If two nodes are selected, such as opposite corners of a rectangle, those two nodes will move in
unison when dragged, and the remaining two nodes will act as anchor points.

EDIT NODES

The node edit tool moves nodes, deletes nodes, and adds nodes.
When the node tool (keyboard N) is selected then the command bar shows various features of
the node edit too.



Add a new node between two selected nodes on the path. . Select the two nodes then click add
node.

CHANGE NODE TYPE



Inkscape has several types of nodes: corner, smooth, symmetric, tangent
The node change tools (in the middle of the command bar when the node edit tool is selected)
converts from one type of node to another.

Corner nodes are where there is a sharp turn in a path, perhaps where two smooth curves
intersect. Corner nodes are drawn as diamonds. End nodes are also considered corners and
are also displayed as a diamond.

Smooth nodes are part of a smooth curve and have control handles. They are drawn as
squares. The ends of the control handles are drawn as circles.

Symmetric nodes have equal length control handles on both sides that will move the same
amount when one control handle is dragged.

FILL COLORS



Fill colors are defined on the Fill and Stroke dialog box. Select the Fill tab. In this image flat fill is
selected with an RGB color. There are linear and radial gradient options. When the mouse
hovers over an icon the name of the property appears in a black box. The sliders below the
icons define the gradients or the transparency fade.

The color selection method in the above image is RGB. Each horizontal color slider is prefixed
on the left with the channel, R, G, B or A for alpha.

There are different ways to pick a color and color gradient. Here’s the Wheel color select option.

STROKE COLORS AND STYLES



On the Fill and Stroke dialog are two tabs for assigning properties to the stroke. The Stroke

Paint tab defines the color or gradient of a stroke.

The Stroke Style defines the width and style.

This dialog also defines how corners will look.



A shortcut is on the bottom status bar. Right click on the Stroke status and a popup menu lets
you select new stroke widths for selected strokes or paths.

Another shortcut is to click on the color palette at the bottom to change the fill color.Use
SHIFT+click on the color palette to change the stroke color.

Double click on the fill or stroke color on the bottom status bar to bring up the appropriate Fill

dialog.



Stroke style can be used to make arrows y changing the markers (start, mid, end) and using the

bezier line tool to draw a straight line.

becomes the line

TWEAK TOOL Tweak Tool

The Inkscape manual has a good section on the tweak tool with illustrations.
https://inkscape-manuals.readthedocs.io/en/latest/tweak-tool.html

Paths can be compressed, rotated, moved, jiggled, colors tweaked, objects roughened.

EYE DROP COLOR PICKER

The eyedropper tool selects the color under the cross hairs. Click on the eyedropper, then put
the cross hairs on the color to select. After the click to select the color a box appears filled the
the color. That color can be used for strokes, fills, or the paint bucket tool.

https://inkscape-manuals.readthedocs.io/en/latest/tweak-tool.html


Note: if some object with fill is already selected on the screen, the new color will fill that object.
Better to select the destination object first prior to using the eyedropper.

PAINT BUCKET TOOL

The paint bucket will fill a bounded area with the color selected either by the eyedropper tool or
the Fill and Stroke dialog box. The area must be bounded or nothing happens. For example, it
can’t just fill the background.

GRADIENT TOOL



The gradient tool lets you fill enclosed objects with gradients. With the tool you draw a line from
one edge of an object to the other and it is filled in with the gradient specified in the Fill Colors
tab of the panel.
This allows you to specify the direction of a gradient, and to move it after the gradient has been
applied by dragging an end node of the gradient line. The command bar lets you specify details

about the gradient..

MESH TOOL

A mesh is a specialized gradient that repeats over a tiled pattern.



With nodes showing

Without nodes

In the mesh command bar there are options for number of rows and columns.

A mesh can be defined in the Fill colors tab. Select the object and then click on the mesh
gradient icon in the fill tab.

Meshes can also be added to a selected object with the mesh tool. Existing mesh gradients can
also be edited with the mesh tool.

MEASURING TOOLS
The first level of measuring are the rulers on the sides of the drawing window. These will be in
units set in the File->Document Properties dialog box.



Selecting the object will put a tiny arrow on the ruler showing the location of the center of the

selected object.

To turn on or off the rulers, go to the View->Hide Show menu and uncheck. Or use the keyboard
shortcut CRTL+R



The main measuring tool is the ruler at the bottom of the left toolbar.

The cursor will change to a ruler with cross hairs. Click and drag and when you release the

measurement of the distance between the points will appear, and the angle.

Click or hover over on an object with the ruler and the position and size of the object will appear.

When the Measuring tool is selected the command bar changes to several options for font size,

decimal precision as well as drawing lines to guides.

Use make the measurements disappear press the  escape key to cancel, or CTRL+Z to undo.

The pen tool  Shirt+F6 also shows distances in its status bar at the bottom of the screen.



ROTATE AND FLIP
When an object is selected with the arrow tool, the command bar will show four options:

Rotate left, rotate right, flip horizontally, flip vertically.

Select the object to rotate or flip, then select the command bar operation.

SNAP TO
The right tool bar has options to snap nodes to other nodes when using the drawing tools.
Sometimes you want cusp nodes to snap, and sometimes you don’t. Click on these icons to turn
different types of snap on and off. Roll over each icon to see what kind of snap is controlled by
that icon.



DUPLICATE AND CLONE
Often an artist wants to duplicate or clone a selected object or path. CTRL+D is the keyboard
shortcut to duplicate. The right toolbar has a icons for duplicate and clone objects. As usual,
hover over an icon to get a description and keyboard shortcut.

Cloning and object creates a duplicate that is linked to the original. For example, making a sky
full of stars could be done by cloning. Edits of the original object change the shape of the clone.
ALT+D creates a clone. The cloned object will look like the original but it’s shape cannot be
changed, only its size and rotation.

GROUP AND UNGROUP

Multiple objects can be grouped together (not a union) to be moved or resized as a set.
Ungroup allows the individual objects  that were grouped to be edited separately. Some
operations like bitmap trace

CHAPTER 7: Grid, Layers
GRID

A reference grid can be turned on and off from the “View->Page Grid” menu item by checking
the adjacent box.



To change grid properties go to the File-Document Properties and then the Grid tab on the
dialog box



Create a new grid if needed, then set the grid units, spacing x and y.

GUIDES

When aligning objects or positioning them precisely on the page it’s handy to use horizontal or
vertical guidelines. At the edge of the document window there are rulers which have a black
triangle that moves with the cursor. Click on the triangle and drag down or out and a guideline
will appear.

Click on the guideline and drag to move it about. The properties of the guideline (like selected
color) can be modified in the File->Document Properties dialog in the Guides tab.

The “Create guides around the page” draws guidelines at the top, bottom, right, and left edges
of the document. These guidelines can then be dragged to any desired location.

LAYERS



Although not part of the SVG standard, layers are useful for any graphics. The background of a
scene can be in one layer, the foreground characters can be in another layer. This allows more
convenient reuse of characters, and to change the background easily.

CHAPTER 8: Tracing
Often a raster (bitmap) image exists already so the vector artist can save time by using
Inkscape’s tracing ability to convert color edges to paths, and then edit those paths by hand.
Begin by importing a raster bitmap. For some special effects preprocess in a photo editing
program like GIMP or Krita.

Select the bitmap and choose Path -> Trace Bitmap off the menu.

This brings up an options dialog.



There are three main criteria to use when converting to vector paths. Each approach works

better with different bitmaps.



BRIGHTNESS CUTOFF

Brightness cutoff creates paths when the brightness changes by a certain amount (the sum of

the RGB values). That threshold can be set.

For each bitmap, experiment with different settings to find what appeals. Click the Update button
to see the results of the proposed settings. Click OK when the converted vector drawing looks
okay.

EDGE DETECTION

Create a path/stroke when edges are detected. Might be useful when closed paths are going to
be filled with color manually.

COLOR QUANTIZATION

When a bitmap contains regions of different colors, they can be traced into separate paths using
multiple traces and color quantization. This is a computer intensive operation and makes many
layers and paths, but can produce amazing traces.

TRACE BY HAND

Although Inkscape automatic tracing is amazing, sometimes the bitmap photo is too complex or
parts of the image need to be modified or left out entirely. A technique in Inkscape is to put the
bitmap in its own layer and reduce the opacity of the bitmap. Then create another layer above
the bitmap and use the Bezier drawing tool to trace outlines manually. This takes a while to click
around the bitmap shapes, but the result is much easier to edit and fill with colors.



EXAMPLE OF TRACING
We use a cartoon image from Joe Wos from Wikimedia Commons

https://commons.wikimedia.org/wiki/File:Alien_in_a_UFO_Cartoon.jpg

The goal is to convert this bitmap image to a vector drawing using trace. We select the bitmap
object and then Path->Trace Bitmap…

Here is the trace using edge detection. Might be interesting for editing boundaries but doesn’t
look enough like the original.

https://commons.wikimedia.org/wiki/File:Alien_in_a_UFO_Cartoon.jpg




Here is the trace with Color quantization, 8 layers. Would be a very odd cartoon.

Color quantization can be useful with the Multiple Scans button/tab selected where every color
becomes a separate object in it’s own layer.

Use the brightness cutoff trace method with a threshold of 0.350 to get the following vector trace

which is closest to the line drawn cartoon effect we want.

Before editing we select all paths and then simplify the vector drawing with Path->Simplify or
CTRL+L



We then use the eyedropper to pick colors and the paint bucket to fill the vector drawing areas.
Zoom is your friend here. Here’s the image with flat colors filled in using the eyedrop and paint
bucket tool. Be sure to select the new object to fill before changing the fill color or the previously
selected object will fill up. Note, a bounding box had to be drawn around the image before the
background color could be poured in.

After filling in colors (or before) zoom in and edit the various paths or strokes using the node edit
tool or other tools. You may have to ungroup and even break apart the paths produced from the
tracing process before editing individual paths or nodes.

For more in depth on the basic tracing methods go to the official documentation at:
https://inkscape.org/doc/tutorials/tracing/tutorial-tracing.html

CHAPTER 9: Save and Export
Save Inkscape SVG

By default Inkscape saves in it’s own version of SVG which can store SVG data but also some
information that isn’t included in regular SVG files like tool options of layers.

https://inkscape.org/doc/tutorials/tracing/tutorial-tracing.html


For convenience Inkscape will allow autosave of the current document. That can be turned on

from the Edit menu, Preferences (at the bottom of the menu).



This brings up the preferences dialog box. Select the Input/Output preferences. There are many
preference settings, so scroll down to Input/Output and expand the dropdown menu. Click
Enable Autosave if desired.



Other output options exist on the Input/Output dialog box menu to control details of the SVG file
produced.

SAVE AS PNG

To export as a raster (bitmap/pixel) image, select Export as PNG on the File menu.

That menu item opens up an options panel on the right of the screen to specify PNG features.





SAVE OTHER VECTOR FORMATS

To export as a plain SVG (not the Inkscape version), choose “Save As…”  which brings up a

dialog with many file format options for export.

Plain SVG is a generic SVG file. Inkscape SVG is generic SVG with some extra commands in a
separate extension which stores edits performed, etc. The SVG standard allows extensions so
the Inkscape SVG should render the same as plain SVG but when opened by Inkscape it
remembers some settings.. For example, the open source graphics program Krita will import
Inkscape SVG.



There are many specialized vector formats like PostScript or Flash which the Inkscape file can
be exported to..

EXTENSIONS

There are many addons and extensions available for Inkscape. The Inkscape software works
with Python so it’s easy to write custom extensions, or make libraries of symbols for others to
use.
The inkscape website shares many extensions from the community.
https://inkscape.org/gallery/=extension/

https://inkscape.org/gallery/=extension/

